MYOB Error: You don't have any API licenses
Created by Damien Zwillinger, Modified on Tue, 16 Jul at 9:34 AM by Gabriel Michaud
Applies to:
- Velixo NX
- Velixo Classic
- MYOB Acumatica
Symptom
When using Velixo Reports with MYOB, you get the following message...
... when either attempting to use one of the Velixo Writeback features:
or attempting to update inquiries after receiving a message that inquiries need updating...
Text from Message:
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> PX.Data.PXException: You are not allowed to log in as you don't have any API user licenses
at MYOB.AdvancedLive.Core.Services.LicenseServiceImpl.ValidateUser()
at PX.Data.PXLogin.PX.Data.IPXLogin.LoginUser(String& userName, String password)
at PX.Api.Services.LoginService.Login(String login, String password, String company, String branch, String locale, String prefix)
at PX.Api.ContractBased.ILoginServiceExtensions.LoginForSoapApi(ILoginService loginService, IMultiFactorService multiFactorService, String login, String password, String company, String branch, String locale)
at PX.Api.Soap.Screen.ScreenGate.Login(String name, String password)
--- End of inner exception stack trace ---
Cause
MYOB has special API licensing requirements for certain MYOB features (including inquiry creation and writing data to MYOB from Excel).
Resolution
An API license is required for the task.
Either:
a user with an existing API license must perform the task or
an API license must be assigned to the user attempting the task.
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