Error: Access Denied. A field with the name Ledger.LedgerID cannot be found

Created by Damien Zwillinger, Modified on Thu, 5 Oct, 2023 at 9:35 PM by Damien Zwillinger

Applies to:

  • Velixo NX
  • Velixo Classic
  • Acumatica, Cegid, MYOB


Symptom

When creating a Generic Inquiry using the field Ledger.LedgerID with Acumatica 2020 R1 Update 3 or 2020 R1 Update 4, the inquiry fails and the following error message is displayed:

 

Error_in_Velixo.jpg


Excerpt Text from the Error Message:

 

An error occured during configuration of inquiry
VelixoReportsPro-GLHistoryLastActivity. Please ensure that you
have the necessary rights to create a Generic Inquiry.

 

System.Web.Services.Protocols.SoapException: Server was
unable to process request. ---> 
PX.Data.PXsetPropertyException: Error: An error occurred
during processing of the field Data Fields value
Ledger.LedgerID A field with the name Ledger.LedgerID
cannot be found.

 

Cause

A modification included in Acumatica 2020 R1 Update 3 and 2020 R1 Update 4 renamed the field Ledger.LedgerID to Ledger.ledgerID.

This is planned to be addressed in a future update of Acumatica.

Resolutions

A workaround for this issue has been implemented within Velixo Reports v5.

 

In the meantime, we have created an Acumatica Customization Package that can be used to create all the necessary inquiries. A system administrator can publish it to the Acumatica tenant to avoid this issue.

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