Error: unauthorized_client connecting with Single-Sign-On

Created by Damien Zwillinger, Modified on Thu, 05 Oct 2023 at 05:50 PM by Gabriel Michaud

Applies to:

  • Velixo NX
  • Velixo Classic
  • Acumatica, MYOB Advanced, Cegid XRP Flex


Symptom

When each of the following conditions holds:

  • You're connecting to Acumatica with single sign-on:

  • Your Acumatica version is 2021R2 (build 21.201.0086 or higher).

  • You are not logged in to Acumatica in your browser before clicking the Single sign-on button.

  • On the Acumatica login screen, you use an external identity provider to log in, such as Active Directory or Google Account.

Then, after clicking the external provider button, upon login, you may see the following error: 

Cause

There has been a modification in certain versions of Acumatica 2021 R2 that leads to this bug.  The Acumatica team is working to resolve this issue.

 

 

Solution

The solution is to update your ERP to 2021 R2 Update 4 or newer (build version 21.205.0063 or above).

 

 

Workaround

Use this workaround if you cannot update right now.

 

Before clicking the Single sign-on button in Velixo, open your default Web browser and ensure you are logged into the ERP system.

 

If you're using Velixo NX with Excel for Mac, you may need to log into your ERP using the Safari web browser (as opposed to your default web browser).  This is because Excel for Mac uses Safari for display purposes.


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